Wednesday, December 17, 2008

IE Bugged By Bug.

Microsoft recently admitted that a critical new bug affects all IE browsers.

"Microsoft said research confirmed that the bug is within all its browsers, including those it currently supports -- IE5.01, IE6 and IE7 -- as well as IE8 Beta 2, a preview version that the company doesn't support through normal channels.

Users running any of those browsers on Windows 2000, XP, Vista, Server 2003 or Server 2008 are at risk, Microsoft said."

Okay, do you want your Windows system to be more secure than it is right now? Do you want to reduce the risk? The solution is simple. Run the Firefox browser, not IE.

Firefox 3 is faster, safer and smarter.

Do you REALLY want to be more secure than ever? Get Linux! Linux isn't prone to Windows viruses, Trojans or bugs. And Linux already has Firefox pre-installed!

Get a better Browser. Get a better operating system. Get Firefox. Get Linux.

No comments: